Connecting your keyboard to Piano Planet (iOS)

You can connect your keyboard with Piano Planet. Once connected, what you play on your keyboard also plays in the app.

There are 3 ways to connect your keyboard to your device and use it with Piano Planet:

  1. Bluetooth
  2. USB Cable
  3. MIDI OUT Cable

Currently we do not support microphone detection, so this means you cannot connect an acoustic piano with piano planet.

Bluetooth Connection:

If your keyboard is newer, the easiest option is to connect by Bluetooth. If you’re not sure if your keyboard has bluetooth, you can look up your keyboard model online to check. If your keyboard doesn’t have bluetooth, but it does have USB or MIDI ports, you might be able to buy a Bluetooth dongle that would add bluetooth support to your keyboard like this one: https://www.amazon.com/Yamaha-Wireless-MD-BT01-5-PIN-Adapter/dp/B01CFOHF6U

Equipment checklist:

  • A keyboard with bluetooth
  • Your device iPhone or iPad device
  • Downloaded Garage band to device

Bluetooth connection steps:

  1. Get your keyboard ready to accept bluetooth connections.
  2. Open garage band on your iPhone or iPad device.
  3. Tap on “settings” upper right gear icon.
  4. Tap on “Advanced”.
  5. Tap on Bluetooth MIDI Devices.
  6. Search for your keyboard (Make sure your keyboard’s bluetooth is turned on and searchable. It might require you to put it in pairing mode. If you’re not sure how to do this, check your keyboard user manual.)
  7. Connect to your keyboard.
  8. Open the Piano Planet app, and now your keyboard should be automatically connected to the keyboard. You can test the connection by opening the left side menu and selecting “free play”.

Done!

USB Connection:

You can connect to Piano Planet through USB by plugging your iPhone or iPad in with a lightning to Camera USB connector (https://www.amazon.com/Apple-Lightning-USB-Camera-Adapter/dp/B014VGHG0U) and then another USB wire from the connector to your keyboard. Check which type of plugin your keyboard has and double check before you buy.

Equipment checklist:

  • Apple “Lightning to USB camera adapter”
  • Compatible keyboard with USB
  • Your iPad or iPhone device ready

USB connection steps:

  1. Turn on your keyboard and device.
  2. Plug in the adapter and then the USB wire into your keyboard.
  3. Lastly, open piano planet, and it should automatically recognize your keyboard. You can test this by opening the left side menu and selecting “free play”.

Done!

MIDI Connection:

You can connect your keyboard to Piano Planet through MIDI by using what’s called an audio/midi interface that is compatible with IOS devices. When I did my research I settled on this one and am very happy with it: (https://www.amazon.com/Korg-plugKEY-Portable-Interface-PLUGKEYBK/dp/B01HG292GW)

Equipment checklist:

  • Compatible audio/midi interface
  • Keyboard with MIDI OUT
  • A MIDI cable
  • Your iPad or iPhone device ready

MIDI connection steps:

  1. Plug the MIDI cable into the MIDI OUT on your keyboard, and then connect the cable to the audio interface.
  2. Plug the interface into your device, and then also into an electrical outlet rated for that power output.
  3. Turn on the keyboard.
  4. Lastly, open piano planet, and it should automatically recognize your keyboard. You can test this by opening the left side menu and selecting “free play”.

Done!

1 Like

Hello there,

I connected my piano though MIDI IN & OUT to my Scarlett 6i6 interface. Th Scarlet interface is connected to my iPad using the camera connector. My iPad supports the Scarlet and I’m able to play music through my interface.
But the Piano Planet does not seem to receive any notes I play from my piano keyboard. It works the other way around: when I hit a key on my iPad my piano plays that key. What do you think is wrong?

Thank you,
Pascal

@gy7 Hi George could you please assist? :slight_smile:

Just to add a bit of info:
My Piano is a Korg D1. MIDI in and out are connected to the out and in inputs of my Scarlett 6i6 interface. My setup works fine with another app (Piano Notes). So I believe the issue must be related to MIDI channels or something.

Hope this is usefull additional info.
Regards,
Pascal

Hi @phibon,

Sorry for being embarrassingly late to this thread. Thanks for the nudge @Ren :slight_smile:

Quick question, when you connect the keyboard to the phone what’s the name the piano planet app says it connected to?

Hello,

I connected a Yamaha keyboard/piano to an iPhone. Piano Planet shows “Netwerk piano connected”. It is connected; when I play the iOS piano I hear the sounds from the Yamaha. I hope it also works the other way: Piano Planet ‘listens’ to the Yamaha. Is this possible as well?

Setup:

  • Yamaha CLP-535B
  • iPhone SE
  • cable: usb b to iPhone cable (generic cable)

It should… During one of the quizzes in the app what happens when you give the answer by pressing the correct key on your Yamaha piano?

Hi there,

When I connect the Scarlett interface it says: “Netwerk Piano Connected”.

Regards,
Pascal

Hi, When I press a key on the Yamaha piano this does nothing in the app.

BTW. On another app I see two midi devices: Netwerk and Clavinova. Only when the Clavinova is selected that (other) app works. When the “Netwerk” midi device is selected it it does not ‘listen’ to the Yamaha, looks like what I see on piano planet.

More issues for @gy7 :slight_smile:

Also…sounds like maybe there’s a typo since two people are saying they’re seeing the word “Netwerk” rather than “Network”? Or is this something else…? XD

Hello,

I think it is not a typo but related to the language setting in iOS. When I have my iPhone on Dutch/Nederlands it says “Netwerk piano connected”.

When I change to English/UK it says “Clavinova piano connected”. And now the app works as expected: I can use the Yamaha piano as input to the app!
In short: The app works when the language setting in iOS is on English.

(Guess: The app sees two midi devices “netwerk” and “Clavinova”, the app skips ‘network’. This works well in English but in Dutch is it picks ‘netwerk’ piano.)

1 Like

@griffioen42 This is very helpful research. Thank you so much.

The app indeed defaults to network but didn’t realize the language setting has an impact on the device name. In retrospect, it seems like it would.

I will improve this flow to make sure:

  1. We can manually the select the device.
  2. Remember the last device and auto-connect.
1 Like